Mini Truckin'
Click here to find out more!

Drive shaft problems!!

  
Mini Truckin'
Item Posts    Sort Order

Drive shaft problems!!

 
Droppedsdime98 Droppedsdime98
New User | Posts: 4 | Joined: 05/13
Posted: 05/06/13
10:36 AM

I have a 98 s10 ext cab. I believe it was converted from auto to stick before me. I also believe it was converted from single drive shaft to double. No body drop no wheel wells under the hood removed on 18 inch rims. Whenever I cruise low (60 psi front 20-30psi back)or even with the back down (can cruise with driver or pass side down with the other side up and no noise) I get this weird ringing sound (almost sounds like metal on metal sounds like grinding brakes on rotors to describe it best) when I put the clutch in or let my foot off the gas (only really starts when I'm at about 35 mph). My ride height is about 180 psi per corner. Ride height is still pretty low but no sound at that height at all. Was told by one guy I should shorten the drive shaft piece that goes from xmember to trans. But after reading into it and doing alot of research I don't know if that's what I should do. Anyone want to just settle my dilemma? And if I shorten it how much? Confused  

WeAllLoveMeth WeAllLoveMeth
New User | Posts: 3 | Joined: 05/13
Posted: 05/17/13
06:12 PM

I had a problem like that once on my mazda. It ended up being the drive shaft bearing. I went in and replaced the shaft and all was well. I'd look and see if it has any strange play or anything. I know it sucks and hurts the wallet but you may just need a new shaft  

Droppedsdime98 Droppedsdime98
New User | Posts: 4 | Joined: 05/13
Posted: 05/20/13
06:05 PM

That's the weird thing just replaced the transmission and put it all back together and it did this with the old transmission ll have to take a look at it and see if that may be it though thanks ill start looking there and continue from that point thanks